horizontal rule

 

 

 

 

 

www.novell.comwhats_newhow_to_buysearchsite_map

Return to Support Connection Home PageSearch, view, and download technical documents.Search, view, and download patches.Search, read, post technical questions and solutionsAdditional ways you can get supportConfused? Use the assistant to learn about Support Connection

Troubleshooting <b><font color="blue">Nprinter95</a></font></b> Summary Troubleshooting Nprinter95 Summary  (Last modified: 31JUL1998)

This document (2928524) is provided subject to the disclaimer at the end of this document.
Forward this document to a colleague
Submit comment about this document to its author

horizontal rule

Issue

The following documents discuss the NPTWIN95 architecture: TID 2908297
November 1996 Application Note titled "Setting Up Network Printing with Client 32 for Windows 95"

Basic troubleshooting steps:
1. Make certain you have the current version of NetWare NPRINTER Manager by checking the SUPPORT.NOVELL.COM web site. There are multiple versions, and the issue you are experiencing may have been resolved in a new release. The file name to download is NPTR95.EXE. Several versions have been placed on the web with this same file name.

2. Make certain you have the current version of intraNetWare Client32 for Windows95. Many of the Print Provider support files come from Client32 and the issue you are experiencing may have been resolved in a new release.

3. Many configuration problems are related to corrupt/misconfigured NPRINTER.INI files. Rename the NPRINTER.INI in the WINDOWS directory. Restart NPTWIN95.EXE and add the printer again.

4. Check the Nprinter95 Frequently Asked Questions (FAQ) document (TID2907959).

5. In Win95, indicate the frame type(s) for the machine to use. Go to Control Panels, Network, and select IPX 32-bit protocol. Select the Advanced IPX tab and check the box label "Primary logical board". Then choose the frame type used on the server where the print server is loaded.

6. Apply the latest SPXS.NLM to the server.

7. Try running RCONSOLE to the server where the print server resides. RCONSOLE, like Nprinter and Nprinter95 uses SPX communication.

The following is a list of known issues:
Issue 1:
"LPT1 is not supported on this workstation. Please select another printer that does not use LPT1"
or
"[port] is not a supported port" where [port] is any valid serial or parallel port name.

Solutions:
Nprinter95 looks in the registry at this parameter:
[HKEY_LOCAL_MACHINE\Enum\BIOS\*PNP0401\0C]
PortName=LPT1
If the PortName is something other than PortName like PORTNAME it will think the port is not there.
Just deleting the ports and letting windows PNP the configuration back will not necessarily fix the name, when I do this it brings back PORTNAME instead of PortName. Two solutions exist to fix this:

1) Run Regedit
Go into HKEY_LOCAL_MACHINE\Enum\BIOS\
Use menu item Edit / Find type in 'portname'
  Checkmark "Look at" keys, values, and data
  Hit button "Find Next" and find the value PORTNAME
Note the data under portname then rename PORTNAME (right click on it)
Use "PortName" (case sensitive capital P and N the rest small case) hit return.
Right click again select 'Modify'
Enter a value of LPT1 or whatever portname it was. (All CAPS)

It has been reported that some OEM versions of Windows95 will not let you modify the setting as outlined above. For these cases, instead of modifying the name PORTNAME to PortName, delete the string key of PORTNAME and do an Edit / New / string value and call it PortName then open it and add the port name, ie, LPT1 or whatever port you are working with. Alternatively, you can rename PORTNAME to Port and then rename it again to PortName.

2) Putting the following information in the NPRINTER.INI file. Put the appropriate heading(s) for what port(s) you want to use. (assumes printers named P1, P2, P3, P4, and P5.

[NPRINTER]
setup=TILE
tree=&LT;treename&GT;
context=&LT;contextname&GT;

[LPT1]
name=.P1.&LT;contextname&GT;
printer=P1
printServer=&LT;printservername&GT;
number=0
port=7
profile=1

[LPT2]
name=.P2.&LT;contextname&GT;
printer=P2
printServer=&LT;printservername&GT;
number=1
port=8
profile=1

[LPT3]
name=.P3.&LT;contextname&GT;
printer=P3
printServer=&LT;printservername&GT;
number=2
port=9
profile=1

[COM1]
name=.P4.&LT;contextname&GT;
printer=P4
printServer=&LT;printservername&GT;
number=3
port=10
profile=1

[COM2]
name=.P5.&LT;contextname&GT;
printer=P5
printServer=&LT;printservername&GT;
number=4
port=11
profile=1

NPRINTER.INI example for a 3.x bindery queue.
[LPT1]
name=&LT;printername&GT; - &LT;printservername&GT;
printer=&LT;printername&GT;
printServer=&LT;printservername&GT;
number=0 &LT;---- printer number in pconsole
nlm=NPTDRV95.NLM
port=7
profile=1

Issue 2:
Hewlett-Packard HP6P printers print only once. Turning the printer off and on allows the printer to print one time again.

Solution:
Use the HPLJ4 driver in place of the HP6P driver. You could also try using the HP6P driver with bi-directional printing disabled. If the HP6P driver is still not working, try doing a custom install and deselect the toolbox.

Issue 3:
IPX/IP gateway user receives the following error when loading NPTWIN95.EXE:
"Nptwin95.exe cannot connect to print server CN=XXXXX. Error code:44".

Cause:
The IPX/IP gateway uses a different WSOCK32.DLL than the one that ships with Windows95. When this DLL is in place the Nprinter manager can not create the printer. Nprinter manager requires the WSOCK32.DLL that comes with the Windows95 to create the connection a print server.

Solution:
Novell is working on a updated WSOCK32.DLL which will work correctly. Until then the following solution should be a satisfactory work around.
Copy WSOCK32.DLL from the c:\windows\system directory to the same directory that the NPTWIN95.EXE application resides in. The path statement in the AUTOEXEC.BAT needs to have a path for the Client32 subdirectory as well.

Once this is done the GUI Nprinter will work because it will find the Win95 version of the WSOCK32.DLL in the current directory before it searches the path for the IPX/IP gateway version. Other applications will find the IPX/IP gateway version of the file since it is in the path, and use it. If there is not a path to the c:\novell\client32 subdirectory you will get a message stating that "A required .DLL file, WSOCK32.DLL was not found".

Issue 4:
"A required .DLL file, PRTWIN32.DLL, was not found"

Solution:
The PRTWIN32.DLL is one of the support DLLs required for the NPTWIN95.EXE application. It is supplied in the current Client32 kit.
Along with the PRTWIN32.DLL, a version of CLIENT32.NLM dated 7-01-96 or later is necessary in order to make the Nprinter Manager for Windows95 function correctly.

Issue 5:
When starting Nprinter for Windows95, you get the error "Nprinter file '&AMP;0' could not be found".

Solution:
Make sure the directory containing the Nprinter files doesn't have more than 8 characters in his name. For example, a directory containing the Nprinter files called "Nprinter95" will get this error. Renaming it to "Nptr95" solves the problem.

Issue 6:
When sending a print job to a printer managed by Nprinter95, the error "Printer off line" occurs. This problem only occurs when sending a print job from the Windows95 workstation where the printer is physically connected. No problem when sending print jobs from other workstations.

Cause:
The computer where the printer was physically connected was trying to communicate directly to the printer by using the LPT1 port. However, LPT1 was already in use by Nprinter95 which resulted in the "Printer off line" error. Configuring the printer as a "Network printer" instead of a "Local printer" will allow Nprinter to manage ALL the print jobs.

Solution:
Even on the workstation where the printer is physically connected, you should set up a "Network printer" for this printer and not configure it as a local printer. To do that, go into the Printer Folder, delete the printer icon, select "Add printer", press Next, choose "Network printer" (don't choose "Local printer", even though the printer is physically connected to that computer) and browse the tree to find the printer queue.

Issue 7:
How do I get the GUI Nprinter for Windows95 to automatically close when I put it in the startup folder?

Solution:
If you just put Nprinter in the startup it will either automatically connect or not depending on the button set in the "Activate printer when Nprinter Manager loads" box. But either way, you will still have the Nprinter Manager program running in Windows95. To get Nprinter95 to auto load and auto close so the user does not have to have any intervention, put the following parameter in the properties shortcut for nprinter /EXIT.

Add NPRINTER to the StartUp Folder
1. Choose Start, and then point to Settings.
2. Choose Taskbar, and then choose the Start Menu Programs tab.
3. Choose Add, and then choose Browse.
4. Navigate to the NPTWIN95 file, and then double-click it.
5. Choose Next,and then double-click "StartUp."
6. Type the name that you want to see on the StartUp menu (like NPRINTER), and then choose Finish. If Windows prompts you to choose an icon, choose one, and then choose Finish.

Adding /EXIT to the NPTWIN95.EXE executable.
1. On taskbar right click and choose properties.
2. Choose Start menu programs Tab.
3. Choose Advanced Tab.
4. Go into Programs then Startup
5. Right click on Nprinter Program Icon and choose properties
6. Choose ShortCut Tab and under the path and filename in TARGET, put /EXIT at the end of the line.
This will automatically close the Nprinter Manager and leave Nprinter95 after Windows95 startup.

Issue 8:
When trying to connect to a print server on a 3.12 server, the print server shows up, but under the attached printers box, it says &LT;No printers available&GT;

Solution:
Choose the frame type being used on the server as described above in Basic Troubleshooting Step #5. The other reason for this to happen is that all of the printers defined for the print server are already being used on other workstations running Nprinter or Nprinter95.

Issue 9:
Adding a printer in the Nprinter Manager allows you to choose the printer in the dialog, but returns error 45 when trying to connect. Error 45 indicates an SPX establish connection failure. SPX works fine for rconsole, nprinter.exe, etc.

Cause:
This issue is generally an SPX communication problem. Different things can cause this such as LAN card drivers, frame type settings, lan drivers on the server, packet burst, LIP, print server problems, and other client issues.

Solutions:
Try a different LAN driver and or card on the client.
If using an NDIS driver for Client32, try an ODI driver.
If using an ODI driver for Client32, try an NDIS driver.
Disable LIP and packet burst on the client.
Set File Cache Level to 0, and set the frame type to manually as described above in Basic Troubleshooting Step #5.
Update the drivers on the server. Update the server's SPX files. Update the server's PSERVER.NLM
Uninstall Client32 and reinstall it on the workstation.
Get a trace of the workstation loading Nprinter Manager in order to determine where the communication is breaking down.

Search: 44 -44 nptwin95 &AMP;0 nptr95 nptr95.exe -45 45 general faq troubleshooting nptwin95 nptwin95.exe nptr95 nptr95.exe GUI nprinter manager nprinter.exe 95 windows 95 98 microsoft

horizontal rule

Please select if this document solved your problem.

horizontal rule

Document Title: Troubleshooting Nprinter95 Summary
Document ID: 2928524
Creation Date: 05AUG1997
Modified Date: 31JUL1998
Document Revision: 16
Novell Product Class: NetWare OS
Novell BorderManager
Novell Product and Version: intraNetWare
intraNetWare Client 2.12 for Windows 95
intraNetWare Client CD (August 97)
NetWare 3.12
NetWare 3.2
NetWare 4.11
NetWare 4.11 Kayak
NetWare for Small Business

horizontal rule

DISCLAIMER
The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

   Feedback | � 1998 Novell, Inc.